您所在的位置: 首页 > 我的成长 > 今天终于在wamp环境下将Zend Optimizer安装成功了

今天终于在wamp环境下将Zend Optimizer安装成功了

由于这个月有两个商城项目要用SHOPEX来做,而SHOPEX又是用zend进行加密的,那么巧WAMP的环境下又必须重新下载一个Zend Optimizer进行安装配置,才能安装SHOPEX系统,不然的话,就会出现乱码,无法安装。这也许搞晕很多朋友。

我用的系统是XP的,因此我是用WAMP来做PHP的服务器,进行本机测试和开发PHP项目。

因此,如果我要正常安装到SHOPEX在本地服务器上测试的话,就必须给WAMP配置好Zend Optimizer。但我为了安装这个鸟东西,搞了几天还是没有成功安装好!安装好了,启动APACHE就不能正常启动出错。次次,都是一样,根据网上所说的,装后也是一个鸟样!郁闷到我,差点就把WAMP改成XAMPP环境来配置ZEND了。

皇天不负有心人,今天终于不理会网上的一些的说法,自己尝试碰碰运气,装了之后,果然OK了!

呵呵,由于我安装好了,因此没有办法提供图片,现在我就用文字来写下我的安装方法。

首先,肯定是先到网上下载Zend Optimizer软件,现在的版本是3.3的。

下载完后,双击进行安装。由于是英文的,里面主要说的是什么我不懂,我只凭着自己使用软件的经验,进行安装选择。

1、进入安装界面后,按NEXT进入下一步。

2、到了路径选择那儿,点Browse,默认是”C:\Program Files\Zend\ZendOptimizer-3.3.0″,由于我的WAMP是安装在C盘里的,因此我将其修改为”D:\WAMP\zend”。

3、按Next后,可以看到的是服务器的选择,分别为:IIS、Apache1.x、Apache2.x、Othter Web server,在这里我是选择Othter Web server进行安装的,之前都是选择Apache2.x,安装后都是出错APACHE不能启动。

4、单击“Next”进入安装向导提示您确认php.ini的位置(默认是C:\WINDOWS\)这里很重要哦,我的WAMP是装在C盘,因此我必须选择C:\wamp\bin\php\php5.2.11,然后下一步。

5、然后进入APACHE选择界面这里也是根据WAMP的安装目录哪里,C:\wamp\bin\apache\Apache2.2.14。

6、然后按NEXT,进入下一步,这个时候就要关闭WAMP服务器。

7、接下来会弹出很多选择窗口,都选择是,YES就可以了。

8、安装完后,打开C:\wamp\bin\php\php5.2.11\php.ini拉到底下会看到:

[Zend]
zend_extension_manager.optimizer_ts=”D:\P8-Server\local\zend\lib\Optimizer-3.3.0″
zend_extension_ts=”D:\P8-Server\local\zend\lib\ZendExtensionManager.dll”

然后自己手动在下面加上:
zend_Optimizer.Optimizerimization_level=1023
zend_Optimizer.encoder_loader=0

9、这样说明已经安装好了,然后重启一下WAMP服务器。这个时候你就可以安装SHOPEX程序了,不会出现乱码现象了!

嘻嘻,,这样就可以做网站了,看下效果吧!已经安装好的。

请尊重我们的辛苦付出,未经允许,请不要转载 健宇工作室 的文章,鄙视各种无耻的采集行为!

健宇工作室分享区  YY教学频道号:63565426

随机文章:

目前有 13 条留言 其中:访客:10 条, 博主:3 条

  1. 小豆 : 2016年01月19日14:27:53  -9楼 @回复 回复

    我这边wamp集成环境下的php是5.4版本,试过了,还是不成功

  2. 长夜 : 2013年09月30日08:38:17  -8楼 @回复 回复

    高手,谢谢,一步到位,谢谢啦!!!!

  3. wind : 2013年07月23日16:13:58  -7楼 @回复 回复

    搞不定,搞你方法装了二次


    • 管理员
      健宇 : 2013年07月23日23:09:19  地下1层 @回复 回复

      检查下你的PHP版本是多少的,如果是5.3以上的就安装不了的zend的

  4. : 2013年03月18日16:55:36  -6楼 @回复 回复

    我找了一上午没搞定 安装成功了的 我去 还是不行 果断先试下你这个方法

  5. 小谭 : 2012年03月04日12:47:13  -5楼 @回复 回复

    没有找到php.ini啊 ,我这儿是php.ini-development 和 php.ini-production
    是不是这两个都要修改啊?


    • 管理员
      健宇 : 2012年03月05日09:24:28  地下1层 @回复 回复

      就在这里,C:\wamp\bin\php\php5.3.8

  6. alngjun : 2012年02月20日09:27:42  -4楼 @回复 回复

    不行,能不能截个info下,zend optimizer成功后的图啊


    • 管理员
      健宇 : 2012年02月20日10:41:02  地下1层 @回复 回复

      最后一张就是安装成功的截图啊。。。。

  7. 毛毅 : 2011年11月12日23:18:24  -3楼 @回复 回复

    还是不行啊

  8. 刘涛 : 2011年10月30日21:16:19  -2楼 @回复 回复

    我按照你的方法,试了很多次,还是不行啊。

  9. : 2011年09月29日00:03:13  -1楼 @回复 回复

    太感谢了!!!我搞了三天也没弄好,总算碰到救星了555555555


    • 管理员
      李 健 : 2011年09月29日01:12:41  地下1层 @回复 回复

      呵呵,,,现在搞定了吧???

给我留言

39 + 91 = 两数相加后,请输入答案